Downgraded Performance

Incident Report for Mews

Resolved

All operations are now stable and processing at normal times.
Posted Dec 31, 2025 - 16:49 CET

Investigating

We have noticed a downgraded performance of the marketplace operations.
We are currently looking into it.
Posted Dec 31, 2025 - 15:53 CET
This incident affected: Mews Marketplace.