We've confirmed rolling back the problematic issue resolved the incident and the billing screen is back to operational.
Posted Oct 16, 2025 - 14:31 CEST
Monitoring
We have rolled back the problematic issue that was causing the billing screen to not load under certain scenarios. We are now checking with customers if the issue preserves
Posted Oct 16, 2025 - 14:13 CEST
Identified
We have identified the problematic deploy and started the rollback process, we will be checking shortly to see if the issue is persistent