VAT Rate and Tax Code Changes in Finland
Incident Report for Mews
Resolved
Communications have been action and now working on preventative measures.
Posted Sep 03, 2024 - 13:59 CEST
Monitoring
To comply with the latest tax regulations in Finland, Mews has implemented a VAT rate change from 24% to 25.5%, effective 01.09.2024. Additionally, due to this change, it is important to note that the other tax rate codes have also been updated.

Details of Tax Rate Code Changes:
0% -> FI-2024-0% (Previously: FI-Z)
10% -> FI-2024-10% (Previously: FI-L)
14% -> FI-2024-14% (Previously: FI-R)
24% -> (Previously: FI-S)
25.5% -> (new tax rate) FI-2024-25.5%

Important: If your systems or integrations rely on the previous tax rate codes, they must be updated to reflect these new codes.
Posted Sep 01, 2024 - 16:04 CEST