Mews Events page is not loading

Incident Report for Mews

Resolved

The issue related to an expired security certificate has now been resolved.
Our engineering teams have restored normal operation, and services should be functioning as expected. We are reviewing what happened to help prevent this from recurring.
Thank you for your patience while we worked to fix the problem. If you continue to experience any issues, please contact our support team.
Posted Feb 11, 2026 - 09:36 CET

Investigating

We are currently investigating an issue related to an expired security certificate that may impact access to parts of our services on Mews Events. Our engineering teams are actively working to restore normal operation as quickly as possible. We will provide another update as soon as more information becomes available.
We apologize for the inconvenience and appreciate your patience.
Posted Feb 11, 2026 - 09:08 CET
This incident affected: Mews Events.