Identity document scanning in Mews Operations is failing intermittently

Incident Report for Mews

Update

Since 23 July, 10:53 UTC, scanning identity documents in guest profiles is failing intermittentlyl roughly half of scan attempts return an error. This is caused by rate limiting at the third-party service that processes document images; we have confirmed the issue is not related to any Mews release and are working on restoring full service.

Workaround: retrying the scan usually succeeds after one or two attempts.
Posted Jul 23, 2026 - 15:58 CEST

Investigating

We are currently investigating reports of an Mews identity scanner malfunction. The Mews team is actively working to identify the cause, and we will provide updates as soon as possible.
Posted Jul 23, 2026 - 14:33 CEST
This incident affects: Mews Operations.