Bills can only contain up to 0 items

Incident Report for Mews

Resolved

The issue is now fully resolved. Us and customers confirmed they are now unblocked and can close bills.
Posted Jul 09, 2026 - 16:24 CEST

Monitoring

We have resolved the issue, customer are confirming that bills can be closed again. We are monitoring the systems now before we close this incident
Posted Jul 09, 2026 - 16:14 CEST

Identified

The Mews team identified the issue and is working on a resolution. Further updates will follow as we make progress.
Posted Jul 09, 2026 - 16:10 CEST