Downgraded Performance

Incident Report for Mews

Resolved

We've been able to identify the cause the performance issues out to be an unplanned migration work on the side of our cloud provider, Microsoft Azure.
Posted Sep 09, 2026 - 22:54 CEST

Update

We have narrowed the problem to be related to a maintenance event performed by our cloud provider Microsoft Azure on our production database. We are cooperating with them to address the root cause.
Posted Sep 09, 2026 - 22:19 CEST

Update

We've been able to resolve the cause of the incident. The app had around 10-second response time or was unresponsive for the end users. The system is functional, we are working on containing the root cause. More updates soon.
Posted Sep 09, 2026 - 21:42 CEST

Monitoring

We're investigating the issue.
Posted Sep 09, 2026 - 21:38 CEST

Investigating

We have noticed a downgraded performance of the system.
We are currently looking into it.
Thank you for your patience.
Posted Sep 09, 2026 - 21:30 CEST