Between approximately 12:43 and 12:55 UTC on 3 November, users experienced degraded performance (slow loading and API timeouts). Services have returned to normal and remained stable since.
We continue to investigate the root cause and contributing factors. Learnings will be incorporated into preventative measures to reduce the likelihood of recurrence.
Posted Nov 04, 2025 - 10:19 CET
Update
Between approximately 12:43 and 12:55 UTC, users experienced degraded performance (slow loading and API timeouts). Systems returned to normal and have remained stable since. We’re continuing to investigate the root cause and contributing factors. We will share more details if a specific trigger is identified.
Posted Nov 03, 2025 - 18:47 CET
Monitoring
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Nov 03, 2025 - 14:23 CET
Investigating
We are currently investigating reports of an issue affecting Mews. The Mews team is actively working to identify the cause, and we will provide updates as soon as possible.