Investigating issues causing delayed verification emails

Incident Report for Mews

Resolved

The issue is now fully resolved. Mews is now operating as expected.
Posted Aug 09, 2026 - 00:09 CEST

Monitoring

We are again sending the authentication verification emails in a timely manner. We keep monitoring the situation.
Posted Aug 08, 2026 - 16:31 CEST

Investigating

We are currently investigating reports of an issue affecting verification email. The Mews team is actively working to identify the cause, and we will provide updates as soon as possible. Emails delivery can be delayed up to 40 minutes.
Posted Aug 08, 2026 - 16:23 CEST