The team has resolved the issue, and we are closely monitoring the system to ensure stability.
Posted Jan 19, 2026 - 19:38 CET
Investigating
We are currently investigating an issue with scheduled exports not working in Mews BI. The Mews team is actively working to identify the cause, and we will provide updates as soon as possible.
Posted Jan 19, 2026 - 12:59 CET
This incident affects: Mews Business Intelligence.