Mews BI data loads without issues. Validation checks showed all data to be reconciled.
Posted Nov 05, 2025 - 08:47 CET
Monitoring
The data has now successfully been processed and customers will now see up-to-date data. We will monitor the next ingestion runs closely.
Posted Nov 03, 2025 - 23:21 CET
Update
We are currently reverting changes that added the large volume of new data so we can process the existing data.
The next update will be provided in 2 hours.
Posted Nov 03, 2025 - 22:02 CET
Update
The ingestion process is ongoing.
The next update will be provided in 60 minutes.
Posted Nov 03, 2025 - 21:01 CET
Identified
The investigation has identified that recent ingestion of a large volume of new data has caused overlap in the process, leading failures later in process. We have increased the amount of resources to improve processing time and are now re-running the ingestion process.
Another update in the next 60 minutes.
Posted Nov 03, 2025 - 20:14 CET
Update
We're currently investigating the issue and will provide another update in the next 30 minutes.
Posted Nov 03, 2025 - 19:39 CET
Investigating
Our data processing infrastructure is experiencing issues causing outdated data to show in Mews BI. No data has been lost and Mews BI will continue to work, however the latest available data is from approximately 08:00 AM - 10:00 AM UTC.
The next update will be provided in the next 30 minutes.
Posted Nov 03, 2025 - 19:09 CET
This incident affected: Mews Business Intelligence.