Guest names masked for authorized users

Incident Report for Mews

Resolved

We identified the root cause of the issue where guest names were displayed as ****** for some authorized users. The change causing the issue has been reverted, and guest names are now displaying correctly again.
Posted May 06, 2026 - 17:58 CEST

Investigating

We are currently investigating an issue where guest names are being displayed as ****** for some users, including users who should have permission to view this information. This has been confirmed across multiple properties and may affect operational workflows during active check-in periods. Our teams are investigating the cause and working to restore normal visibility as soon as possible.
Posted May 06, 2026 - 17:48 CEST
This incident affected: Mews Operations.