Issues with Stripe Terminal Payment Completion

Incident Report for Mews

Resolved

The issue has been fully resolved. All payments are now in their correct final states—either completed or appropriately marked as failed. No further impact is expected.
Posted Sep 16, 2025 - 17:50 CEST

Monitoring

The root cause has been resolved. New payments are processing without delay, and we are actively monitoring previously impacted payments.
Posted Sep 16, 2025 - 17:00 CEST

Investigating

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Sep 16, 2025 - 16:43 CEST
This incident affected: Mews Payments.