Reservations from Channel Managers
Incident Report for Mews
Resolved
The potential issue has been investigated and we have confirmed that Mews is fully operational.
Posted Sep 09, 2024 - 06:18 CEST
Investigating
We are currently investigating a potential issue with Reservations being synced from Channel Managers.

Thank you for your patience.
Posted Sep 09, 2024 - 05:32 CEST