Issue with Mews Kiosk and OCI Generating Registration Cards

Incident Report for Mews

Resolved

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Jun 24, 2026 - 13:00 CEST

Identified

The Mews team identified the issue and is working on a resolution. Further updates will follow as we make progress.
Posted Jun 24, 2026 - 11:29 CEST