The issue is now fully resolved. Mews is now operating as expected.
Posted Apr 20, 2026 - 14:42 CEST
Identified
We believe we have narrowed down the cause and remediated this. We're observing an improvement in performance and are continuing to monitor this closely.
Posted Apr 20, 2026 - 11:43 CEST
Investigating
We have noticed a downgraded performance of the system. We are currently looking into it. Thank you for your patience.