Investigating issues with Mews Kiosk

Incident Report for Mews

Resolved

The issue is now fully resolved. Mews Kiosk is now operating as expected.
Posted Jun 20, 2025 - 14:52 CEST

Monitoring

The team has resolved the issue, and we are closely monitoring the system to ensure stability.
Posted Jun 19, 2025 - 18:20 CEST

Investigating

We are currently investigating reports of issues affecting Mews Kiosk. Customers are reporting that guests can't progress from registration card and are unable to submit the data.

The Mews team is actively working to identify the cause, and we will provide updates as soon as possible.
Posted Jun 19, 2025 - 16:14 CEST
This incident affected: Mews Guest Experience.