We are working closely with both Cloudflare and Microsoft Azure on the network connectivity issue affecting some US customers routed through Cloudflare’s Boston data center. The problem remains isolated to specific ISPs, and Mews infrastructure is fully operational. Further updates will follow.
Posted Nov 20, 2025 - 01:36 CET
Update
Intermittent connectivity issues persist for some US customers. We’ve confirmed that the issue is isolated to users whose traffic passes through Cloudflare’s Boston data center, mainly on RCN/Astound and Comcast connections. Mews infrastructure is operating normally, and the problem is limited to specific network paths outside our control.
We are actively working with Cloudflare to restore normal service and will continue to share updates.
Posted Nov 20, 2025 - 00:12 CET
Update
We have identified that the intermittent performance issues reported by some customers in the United States are related to connectivity between certain local Internet Service Providers (primarily RCN/Astound and Comcast) and Cloudflare’s Boston point of presence (PoP).
Posted Nov 19, 2025 - 22:16 CET
Identified
We are currently investigating reports of an degraded performance issue affecting Mews for a subset of customers in the US. The Mews team is actively working to identify the cause, and we will provide updates as soon as possible.