Return icon showing on all reservations on the timeline

Incident Report for Mews

Resolved

We've verified that the return icon is no longer showing incorrectly for all reservations on the timeline. We think the impact from the issue is over.
Posted Jun 25, 2026 - 13:58 CEST

Identified

We are aware that customers are seeing the return icon on all reservations on the timeline.

The Mews team identified the issue and is working on a resolution. Further updates will follow as we make progress.
Posted Jun 25, 2026 - 13:49 CEST
This incident affected: Mews Operations and Mews Guest Experience.