Updates to channel manager connections are delayed.

Incident Report for Mews

Resolved

They delayed updates were processed successfully.
Posted Nov 19, 2025 - 16:58 CET

Identified

Price, restriction and availability updates to channel manager connections are delayed.
We found the root cause.
We are increasing throughputs to resolve the delay.
Posted Nov 19, 2025 - 16:43 CET
This incident affected: Mews Marketplace.