Kiosk: Customers are unable to Check-in/Check-out

Incident Report for Mews

Resolved

Kiosk v4.44.0 has been released, and the issue has been fully resolved.

Customers currently using version v4.43.0 are kindly requested to update to the latest version to resume normal operations.

We appreciate your patience and sincerely apologise for any inconvenience caused.
Posted Nov 11, 2025 - 13:50 CET

Monitoring

We have temporarily disabled the Split Bills functionality on Kiosk in version 4.43.0. This change will remain in effect until the fix is released to app stores and available for installation.

We sincerely apologize for any inconvenience this may cause and appreciate your understanding.
Posted Nov 10, 2025 - 17:01 CET

Identified

An issue is impacting both guest check-ins and check-outs across properties with. Guests with failed or cancelled payments are unable to proceed through Kiosk to settle their bills or complete their stay. This is resulting in blocked check-ins and check-outs, with manual staff intervention required in every case.

We have identified the cause and we're working on a new version.
Posted Nov 10, 2025 - 16:28 CET
This incident affected: Mews Guest Experience.