Updates to channel managers are delayed

Incident Report for Mews

Resolved

Abnormal amount of updates from external partner overloaded the system which caused the delay of updates.
The problematic updates were cancelled and all the waiting updates to be synchronized had been processed.
Posted Oct 28, 2025 - 17:05 CET

Investigating

We're investigating the issue of delayed updates.
Posted Oct 28, 2025 - 14:42 CET
This incident affected: Mews Marketplace.