Cannot pickup reservations from availability blocks

Incident Report for Mews

Resolved

The issue is now fully resolved. Mews is now operating as expected.
Posted Nov 07, 2025 - 10:57 CET

Update

Currently working on reverting changes that caused this incident
Posted Nov 07, 2025 - 10:28 CET

Identified

The Mews team identified the issue and is working on a resolution. Further updates will follow as we make progress.
Posted Nov 07, 2025 - 09:59 CET
This incident affected: Mews Operations.