Issues with German internet provider

Incident Report for Mews

Resolved

We think the impact from the issue is over.
Posted Nov 19, 2025 - 18:36 CET

Monitoring

The impact looks limited to a specific german internet service provider. We're working with our vendor to validate this.

The issue looks to have subsided and the graphs are looking nominal again, however we will continue to monitor the situation.
Posted Nov 19, 2025 - 15:19 CET

Identified

We've identified an increase in latency to our services from a specific ISP in Germany. We'll continue to monitor the situation but cannot provide an update as to when this will resolve.
Posted Nov 19, 2025 - 14:40 CET

Investigating

We are currently investigating reports of an issue affecting Mews. The Mews team is actively working to identify the cause, and we will provide updates as soon as possible.
Posted Nov 19, 2025 - 14:27 CET